Jump to content

Windows Autoupdate is not working


Recommended Posts

I am having Windows XP Service Pack 3 and I am having issues with the autoupdates. The last 2 or 3 days I got the notification in my taskbar that my auto update is turned off and asks me to go to control panel to tyrn it on. But it is turned on there.

I tried doing a manual update using the windows update page, but there once I select the express install, I get

The website has encountered a problem and cannot display the page you are trying to view. The options provided below might help you solve the problem.

For self-help options:

For assisted support options:

So I am not able to do any updates. I have Zonealarm firewall, AVG antivirus & spybot in my system.

Thanks for the help.

Link to post
Share on other sites

:welcomewf:

This "can" be one of the symptoms associated with a malware infection. In any case it will do no harm to run Malwarebytes free version in "Safe Mode" before going any further.

Also think of using "System Restore" to enable you to go back to a place in time when this wasn't a problem for you. (If you do this, run Malwarebytes once again.)

File/Registry corruption, and malware are often the causes of Windows Update functions failing.

(As is the completely unnecessary use of registry cleaners)

There is an excellent (Free) tool available from "Major Geeks" which may help you not only with the current problem, but also serve you well in the future.

Repair Windows Updates

"If windows updates are not working then this repair may help. This will reset windows updates and get all the windows update files registered. Run this repair if windows updates are failing and is not working correctly."

You can download it here:

http://majorgeeks.co...pair_d7141.html

Read more about it here:

http://www.tweaking....all_in_one.html

And here is a video:

[media]http://www.youtube.com/watch?v=3Hnn_VdJJBQ

Link to post
Share on other sites

Thanks for the replies. I tried both, but it was not successful. But I just noticied the error message

Error number: 0x80070424 on the top right corner of the screen and I searched using that and I got

Click on Start -> Run

and paste the command below and enter

%SYSTEMROOT%\SYSTEM32\REGSVR32.EXE %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL

It works now, though had to install lot of updates. I apologize for missing the error message yesterday. Thanks again for the help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy