Jump to content

Recommended Posts

I have a new Western Digital external hard disk, which be with me like 2 months. Well, here's the problem, when i tried to open the content, my computer cannot read the external hard disk. Then i waited for several minutes, it does appear on my my computer section, but it does not shows what it suppose to show (like the hard disk capacity meter and the name of the hard disk). All it tell is 'CD Drive (G:)', and when i double click on it, it tells 'application not found'. I have check it on device manager, it shown over there, but like what i said, i cant open it no matter what. I run auto play, also does nothing. Also i google most of the solution tell me to use Disk Management, which they give solution to change the drive letter, i done it, but still effect nothing. It still the same. I've tried on others computer, failed. I change the usb chord, including the usb booster, failed. The disk inside the device are still running/spinning, and most of WD hard disk have the tiny LED light that indicates its working if it blink so much, but for my problem, the LED light just flashing still motionless. Any solution for this other than formating it, because i cant format it as well! Please help, there's a lot of important task and assignment in there that i need to get it back. Please reply ASAP...thanks


post-23278-0-70836700-1437988594_thumb.j

Link to post
Share on other sites

Can you post a picture of the disk management page.

Actually, there's 2 disks shown over there (which have connection with my hard disk), one shown the hard disk 1, which have down arrow symbol, and saying not initialize...and another saying cd-rom 7, which saying no media, and im pretty sure that is the main problem of this. I set a password for my hard disk, and the storage are still active, but the corrupted WD Unlocker are the one that make problem. It usually shown 'lock' symbol in my computer for me to set the password to access the hard disk content. But, that symbol just gone and replace with another, which basically lead to 'application not found' error. I have tried the WD Driver Utlity and trying to format it as my last source to solve the problem. You know what, it does not allowed me to format the hard disk as well! Now im doubt..

post-23278-0-86688100-1438010931_thumb.j

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy