Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
mechanix19

Laptop Connects to WiFi but Internet Not Available

Recommended Posts

I've been dealing with this issue for a couple years and it's driving me crazy. Everything in my house connects to my main wifi signal without issues. My laptop however connects to the signal but I cannot get internet or see any devices. I always have to be on my guest network with my laptop. I've tried resetting my router, updating the firmware in the router, renaming the main wifi signal, resetting my wireless network adapter on my laptop, updating the the network adapter firmware in my laptop, and reinstalling the network adapter. I have no idea what else to try but I'm fed up not being able to use my laptop to simply print to my wireless printer or setup various electronics with my laptop. Any suggestions would be appreciated. Thank you

Share this post


Link to post
Share on other sites

Does the laptop connect to the internet OK by ethernet cable ?

 

Have you tried it with a USB wireless "dongle" after first disabling the built-in wi-fi aerial ?

 

Have you (by pure accident) blocked its MAC address in your router ?

Share this post


Link to post
Share on other sites

Yes it connects fine with a cable, no I haven't tried a sub wireless dongle, and I'm not sure how to checking a MAC address is blocked in my router. If I connect to my main wifi, I try to login in to my router, I get the prompt for my username and password but then it says server not found after I put the login info in. I can login in to my router on any other device.

Share this post


Link to post
Share on other sites

Yes I've tried the "forget this network" many times. I'm showing through my router logs my laptop will frequently connect than disconnect when I connect to the main wifi signal. However this doesn't happen if I use the guest network.

Share this post


Link to post
Share on other sites
15 minutes ago, Boris said:

Re the possible MAC address blocking - look at Page 52 of this - http://www.downloads.netgear.com/files/GDC/WNDR3700V5/WNDR3700v5_UM_03Sept2015.pdf

 

My router doesn't show this option when I'm logged in, I have version 1 of this router and these instructions look like they apply to a newer version. I did look in the blocked services section of my router and nothing is listed.

Share this post


Link to post
Share on other sites

The details in the Windows  "fix connection issues" says this in the details- windows sockets registry entries for network connectivity are missing. What does this mean?

Share this post


Link to post
Share on other sites

Not sure if this will help, but I found it in a search:  HERE

More info in the link above.

 

Quote

 

open CMD with admin rights, type:

ipconfig /release;

ipconfig /renew;

 

 

I presume you will need to press 'enter' after each entry.

Share this post


Link to post
Share on other sites

A simple question, have you tried resetting your Router. Find the reset button and give it a push, see what happens after it has reset. 

Share this post


Link to post
Share on other sites
21 hours ago, mechanix19 said:

 I've tried resetting my router, updating the firmware in the router

Already done Gandalph :smile:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy